In this article, we describe how to transform geoid (undulation grid in GeoTIFF format) to another datum. 

In the example below, we show how to transform AUSGeoid09 geoid model (EPSG::5111) downloaded from our web-site

from GDA94 to GDA2020 datum and create the compound coordinate system on GDA2020 datum.

The sample file for AUSGeoid09 can be downloaded from the following page: https://www.agisoft.com/downloads/geoids/


Import geoid in project Metashape. 

At first, we import geoid as DEM in the project. Before import geoid, you need to save the empty project in PSX format. Then select File > Import > Import DEM...




Transform DEM

In this step, we transform DEM to another coordinate system (in this example from GDA94 to GDA2020).

Select DEM in the Workspace pane to be transformed, right-click on its label and select Transform DEM... command from the context menu (or use a corresponding option in Tools Menu). Set GDA2020 coordinate system in the Coordinate System field.

Note: that you should select Geographic coordinate system - not Projected coordinate system!



Press OK button to apply the transformation to DEM. When asked to replace the default DEM, use No button in order to create a new DEM instance with the calculation result. 




Export Transformed DEM


Select File > Export > Export DEM... Check Coordinate System for export DEM in the Export DEM dialog window:

 



Create Compound Coordinate System 


Create a new chunk in your project. Open coordinate system selection dialog (for example, in the Reference pane settings), select coordinated system (we chosen GDA2020 / MGA zone 50), and press Edit button. 



Modify the new name of the coordinate system that will be created: 




In the Vertical CS field click on Custom option at the beginning of the list, then in the newly opened dialog input the name of the vertical CS that is planned to be used:



Select "Add..." option in the Datum field, in the file browser window select the file with the undulation grid (the newly created GeoTIFF for AUSGeoid09 in GDA2020 coordinate system), click OK to confirm the selection. 



A newly created compound coordinate system will appear in the section of User-defined coordinate systems and will be available for selection at any time when working on future projects. You may want to save it to an external PRJ file, just in case.