Normally the whole photogrammetric processing workflow is performed completely in Agisoft Metashape. But in some cases the project might require to perform final bundle adjustment in some particular software. In this tutorial we will show how Agisoft Metashape can be used together with BINGO bundle adjustment solution.

Create Agisoft Metashape project

Start Agisoft Metashape. Select Add Photos command from the Workflow menu and add images for processing.

Metashape will automatically load GPS coordinates recorded in EXIF meta data during the flight.


If image coordinates are not available in image meta data, they can be imported separately using File->Import->Import Reference… command.


After image coordinates are loaded, there positions will be displayed in the Model view:

Align images

Select Align Photos… command from the Workflow menu to perform image alignment.


Configure suitable parameters in the Align Photos dialog. In most cases you will be using High accuracy, Generic and Reference preselection options turned on and Reference preselection mode set to Source. Click OK to start image alignment.

After alignment is complete the estimated camera positions and tie points will be displayed in the Model view:

Add control points

If you have measured control points for the project, they need to be loaded in Metashape before exporting data to BINGO. The recommended way to set up control points in Metashape is to load GCPs coordinates using Import Reference… command, and to measure image coordinates in all images where control points are visible. For additional details on the control points measurement please refer to Aerial data processing (with GCPs) tutorial.


Thin Point Cloud

For efficient processing BINGO requires a small amount of high quality tie-points – much smaller than the number of tie-points usually generated in Metashape.


To reduce the number of tie points generated in Metashape select Tools->Tie Points->Thin Point Cloud… command. In the Thin Point Cloud dialog configure suitable number of tie points to be retained per image. We recommend to set Tie point limit to 1000 for BINGO export. Click OK button when done.

1000 points per image is slightly more than required by BINGO, but this excessive number will allow to perform additional thinning in BINGO for best results.

Export BINGO project

After initial alignment in Metashape is complete, a BINGO project with tie points, control points and initial camera orientation parameters can be exported.


Select File->Export->Export Cameras… command. Select BINGO Project (*.dat) from the Save as type list and browse to the folder where the BINGO project needs to be saved.


In the Export Cameras dialog select image axis orientation so that X axis points in the flight direction. Turn off Include invalid matches option to make sure that exported tie points do not contain outliers. Configure other options according to your requirements and click OK button to start export.

Open BINGO project in BINGO Manager

Start BINGO Manager. Select File->Select Project command and browse to the folder with BINGO project exported from Metashape.

Thin tie-points in BINGO

Select Samba command from Tools->Auxiliary menu to start SAMBA program for additional tie-points thinning.

Turn on Save any existing output file to old… and Remove obsolete points from file options.


Click Format button to load camera format from the project. After the camera format is loaded, click Run button to perform thinning operation.


Close SAMBA program once finished.

Run bundle adjustment in BINGO

Select Bingo command from the Run menu to start adjustment. After adjustment is finished, select Skip command from Run menu to apply the skip file created.

Examine bingo.lis file for adjustment results. If adjustment results are not satisfactory, continue running Bingo and Skip commands, inspecting the bingo.lis file after each iteration.


Close BINGO Manager when final adjustment is finished.

Import adjustment results in Metashape

Open the original Metashape project.


Select File->Import->Import Cameras… command. Select BINGO (*.dat) file type and browse to the itera.dat file in the BINGO project folder.


In the Import Cameras dialog select the same image orientation you were using for export and click OK button to import BINGO adjustment results.

In the Open Distortion Grids dialog select distortion grids created in BINGO if any. If there were no distortion grids created, click Cancel.

Proceed with remaining processing steps

After importing BINGO adjustment results, you can proceed with other processing steps such as required for your project: build dense point cloud; building digital elevation model (DEM); building orthomosaic, build tiled model. You can find description this steps in our solutions - Aerial data processing.