This tutorial describes the steps that should be performed in Agisoft Metashape Professional in order to apply the realistic colors from the photographs to the uncolored laser-scanned point cloud for the same area acquired from the different source (for example, aerial LiDAR).


In the example below, we will consider the case when the images do not have any Reference data, so before starting the Colorize dense cloud procedure, it would be required to use markers to align the photogrammetric solution and imported LiDAR point cloud in the same coordinate system.


We are grateful to YellowScan for providing the dataset for this tutorial.


The procedure will consist of the following main steps:

- loading images to the project,
- camera alignment,

- importing external point cloud,

- referencing photogrammetric alignment to the external point cloud,

- performing the colorization procedure.



Add photos


1. Select Workflow Menu > Add Photos command to load the image set to the project. 


2. Click OK button and images will be loaded to the project.



Align photos


1. Select Workflow Menu > Align Photos command. 


2. Choose the parameters to the align process in the Align Photos dialog window.



3. The progress dialog box will appear, displaying the current processing status. The tie point cloud with the results of the camera alignment will be displayed in the Model view after the operation is completed:



NOTE: 

  • In this example we have alignment results without referencing data because no geotags were available in the image  EXIF meta data and no GCPs were provided


Import dense cloud from the external source (LiDAR)


1. Select File Menu > Import > Import Points command.


2. Select the file with the point cloud data for import in the desired format (for example, LAS) and confirm the coordinate system from the list in the coordinate system selection field. 



3. The uncolored point cloud would appear shortly in the Model view (in Dense Cloud view mode). 


Set the coordinate system for a chunk 


Set the same coordinate system for chunk as the imported LiDAR point cloud has. Click the Settings button on the Reference pane toolbar.


Select proper coordinate system for the chunk and markers in the Reference Settings dialog: 



Add markers and reference the camera alignment to the dense point cloud


To align the cameras to the LiDAR point cloud it is necessary to create markers on the point cloud and define their projections on the source photos. 


NOTE: 

  • At least three markers that do not lay on the same line are required. More markers allows for better alignment accuracy, we can suggest to use 8-12 markers.


To create the marker switch to Dense Cloud Classes mode in the Model view (in order to see the shape of the scanned area), then right click in the distinguishable point of interest and select Add Marker option from the context menu, repeat for several points.


After the markers are added, open the image in the Photo view where the corresponding to the marker point is visible, right-click in the point of interest and choose the corresponding marker from the Place Marker sub-menu.

Place projections for each marker on at least two aligned images:




After at least two projections are placed for each marker, you need to check on the markers on the Reference pane and click the Update button on the pane's toolbar in order to apply the referencing information to the camera alignment: 



After that you can use Filter Photos by Marker option for each marker (from the Reference pane context menu) in order to adjust the projections for markers or add new projections on additional images. If projections have been added or adjusted do not forget to click Update button on the Reference pane toolbar again in order to apply adjusted information.



NOTE:

  • If the original image set has georeferencing information, such as coordinates of the camera locations or ground control points (GCPs), you can skip manual markers step, as the camera alignment will be then automatically georeferenced in the same coordinate system with the imported point cloud.

After camera alignment is properly referenced to the external point cloud proceed to the final colorization step:


Colorize dense cloud 


1. Select Tools Menu > Dense Cloud > Colorize Dense Cloud command. 


2. Select the Source data for the dense cloud colorization as Images.



NOTE: 

  • Dense cloud colors can be sampled from the orthomosaic. This option is typically faster than the image-based method but can produce ghosting artifacts in shadowed regions. For Orthomosaic based colorization, it is required to generate orthomosaic first or import it from the external source, providing that it is georeferenced in the same coordinate system.


The dense points cloud will be colorized according to the selected source data (switch to the Dense Cloud display mode in the Model view): 




Export colorized dense point cloud 


The colorized dense point cloud can be exported using File Menu > Export > Export Points command: