The tutorial below describes the main workflow processing steps and recommended parameters for the aerial data processing in Agisoft Metashape Professional without the use of ground control points (GCPs). The project data is collected with SenseFly eBee.

Also the procedure of the accuracy validation with the check points is described.


*You can also watch our joint webinar with the SenseFly team - Exploring eMotion 3.5.0 & Processing with Agisoft Photoscan.


You can save the project in SenseFly as an Agisoft Metashape project by selecting the corresponding item in the program dialog window (.psx file format). After the project has been saved, it can be opened in Metashape. 


Open project.


1. Select Open... command from the File menu. 


2. Select project file in Open file dialog window. In the Model window of the program the positions of the cameras will be displayed during shooting. 

(If there's no existing project, use Workflow Menu -> Add Photos command to select the images that should be processed).



Align Photos

Photo Alignment processing step includes feature points detection, image matching, aerial triangulation and bungle adjustment procedures. 


1. Select Workflow > Align Photos.


2. Set the parameters in the Align Photos dialog window:



The results of this processing step comprise estimated external (camera position + orientation) and internal parameters and sparse point cloud as a visualization of triangulation for matched feature points procedure. Results of the first processing step displayed in the Model view: 


Optimization procedure

Metashape estimates internal and external camera orientation parameters during photo alignment. This estimation is performed using image data alone, and there may be some errors in the final estimates. The accuracy of the final estimates depends on many factors, like overlap between the neighboring photos, as well as on the shape of the object surface. These errors can lead to non-linear deformations of the final model. 


To see errors, after alignment process, click View errors button and the errors will appear on the Reference pane


 

Generally optimization may be helpful, especially when you want to get more accurate results. Possible non-linear deformations of the model can be removed by optimizing the estimated point cloud and camera parameters based on the known reference coordinates. During this optimization Metashape adjusts estimated point coordinates and camera parameters minimizing the sum of reprojection error and reference coordinate misalignment error. 


1. Click Optimize toolbar button on the Reference pane:



2. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized. 

In some cases, when the precise camera locations are loaded and no GCPs are used it may be reasonable to enable "Fit additional corrections" option in the Optimize Cameras dialog in order to improve the accuracy of the processing results.


3. Click OK button to start optimization. 


Check points 

In Metashape you can use two types of markers. They are control and check points. Control points are used to reference the model. While check points are used to validate accuracy of the camera alignment and optimization procedures results.


To load check points coordinates from a text file:


1.  Click Import Reference button on the Reference pane. 



Browse to the file containing recorded reference coordinates and click Open button. 


2. Set the parameters for the import in the Import CSV dialog window:



3. Click OK button. 


Select Yes to All button to create a marker: 


The projections of the markers (check points) should be adjusted manually on the images where the corresponding point is visible. Right-click on the marker in the Reference pane and select Filter Cameras by Marker option in the context menu. Then review the filtered images in the Photos pane and repeat the operation for each marker.




You need to refine marker locations manually in the Photo view mode by dragging their projections on the corresponding photos into correct position. Move the marker projection to the desired location by dragging it using the left mouse button, once the marker location is refined by user, the marker icon will change to Green flag:



To make markers be treated as check points, select marker on the Reference pane. Ensure that the selected marker has at least two projections placed on the aligned images. The check boxes for the corresponding markers should be disabled in the Reference pane. If the check box is enabled, the point is the control point. When check box is disabled, the marker is the check point. 


Note: After you change the point type click Update button from the Reference pane. 


Build Dense Cloud


1. Select Build Dense Cloud command from the Workflow menu.


2. In the Build Dense Cloud dialog box select the desired reconstruction parameters and click OK button. 



  • Higher quality settings can be used to obtain more detailed and accurate geometry, but they require longer time for processing.
  • Mild depth filtering option is recommended.


3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button. 



Build DEM (DSM)

A DEM represents a surface model as a regular grid of height values. DEM can be rasterized from a dense point cloud, a sparse point cloud, depth maps or a mesh. DEM is calculated for the part of the model within the bounding box. 


1. Select the Build DEM... command from the Workflow menu.


2. In the Build DEM dialog box set parameters. 




3. Click OK button. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.


More than one instance of DEM can be stored in one chunk. In case you want to save current DEM instance and build new one in current chunk, right-click on DEM and uncheck "Set as default" option. You need to do this step before building DTM.


Build DTM 


To start generation DTM we need at first to classify the ground points. For this procedure select Tools > Dense Cloud > Classify Ground Points... This feature automatically extracts the ground points from the all the points in the Dense Cloud.



Parameters depend on the project, you need to adjust the parameters according to the terrain type and the project area. So if the first result does not fit your needs, you need to reset the classification and adjust the parameters and see how result is getting better. You can find description about classification in Metashape in the related tutorial or in Agisoft Metashape Pro user's manual


1. Select the Build DEM... command from the Workflow menu.


2. In the Build DEM dialog box set parameters. For build DTM you need select the Point classes


3. Click OK button. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.


In Metashape you can perform the measurements based on the Digital Elevation Model. More detailed information is available in the related tutorial - DEM based measurements.

Build Orthomosaic 


1. Select the Build Orthomosaic... command from the Workflow menu.


2. Set parameters in the Orthomosaic dialog window.  



3. Click OK button. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.



Exporting the results


Export Point:

To export sparse or dense point cloud

1. Select Export Points... command from the File menu. 


2. Browse the destination folder, choose the file type and print the file name. Click Save button.


3. In the Export Points dialog box select desired Type of point cloud - Sparse or Dense. Specify the coordinate system and indicate export parameters applicable to the selected file type, including the dense cloud classes to be saved. 



4. Click OK button to start export. 


5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button. 


Metashape supports point cloud export in the following formats: Wavefront OBJ (*.obj); Stanford PLY (*.ply); XYZ Point Cloud (*.txt); ASPRS LAS (*.las); LAZ (*.laz); ASTM E57 (*.e57); Topcon CL3 (*.cl3); ASCII PTS (*.pts); Autodesk DXF (*.dxf); U3D (*.u3d); Adobe PDF (*.pdf); Point Cloud Data (*.pcd); potree (*.zip); Cesium 3D Tiles (*.zip); Agisoft OC3 (*.oc3).


Saving color information of the point cloud is not supported by the OBJ and DXF formats. Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF formats.


Export Orthomosaic:


1. Select Export Orthomosaic... command from the File menu.


2. In the Export Orthomosaic dialog box specify coordinate system for the Orthomosaic to be saved in. Check Write KML file and/or Write World file options to create files needed to georeference the orthomosaic in the Google Earth and/or a GIS.


3. Click Export... button to start export. 


4. Browse the destination folder, choose the file type and print in the file name. Click Save button. 


5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.


The following formats are supported for orthomosaic export: TIFF/GeoTIFF (*.tiff); JPEG2000 (*.jp2); JPEG (*.jpg); PNG (*.png); BMP (*.bmp); Google Earth KMZ (*.zip); MBTiles (*.mbtiles); World Wind Tiles (*.zip); Tile Map Service Tiels (*.zip).


Export DEM:


1. Select Export DEM... command from the File menu. 


2. In the Export DEM dialog specify coordinate system to georeference the DEM. Check Write KML file and/or Write World file options to create files needed to georeference the orthomosaic in the Google Earth and/or a GIS.


Note: In Metashape DEM export colored from RGB palette is supported. Select Palette option in the Raster transform section of the Export DEM dialog box. The palette option is supported for the following export formats: TIFF, JPEG, JPEG2000, PNG.


3. Click Export button to start export. 


4. Browse the destination folder, choose the file type and print in the file name. Click Save button. 


5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.


The following formats are supported for DEM export: GeoTIFF elevation data (*.tif); Arc/Info ASCII Grid (*.bil); XYZ file format (*.xyz); Sputnik KMZ (*.kmz); Google Map Tiles (*.zip); MBTiles (*.mbtiles); World Wind Tiles (*.zip); Tile Map Service Tiles (*.zip).