Photos suitable for aerial data processing in Agisoft Metashape can be taken by any digital camera (both metric and consumer grade), as long as you follow some specific capturing guidelines. We recommend to read Image Capture Tips section which explains general principles of taking and selecting pictures that provide the most appropriate data for photogrammetric processing. Processing of aerial images with Metashape Professional includes the following main steps: 

  • loading images into Metashape;
  • aligning photos;
  • GCPs input as markers
  • optimizing camera alignment
  • building dense point cloud;
  • building mesh model and generating texture (optional);
  • building tiled model (optional)
  • building digital elevation model (DEM);
  • building orthomosaic;
  • export DEM, orthomosaic;
  • upload data (optional).


The tutorial below describes the main workflow processing steps and recommended parameters for the aerial data processing in Agisoft Metashape Professional.


Add Photos

1. To add photos select Add Photos... command from the Workflow menu.

2. In the Add Photos dialog browse the source folder and select files to be processed.


Align Photos

Once photos are loaded into Metashape, they need to be aligned. At this stage Metashape estimates the camera position and orientation for each photo and generates a sparse point cloud consisting of the tie points.


1. Select Align Photos... command from the Workflow menu. 


2. In the Align Photos dialog box select the desired alignment options.


3. Click OK button.


4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button. 


5. Alignment having been completed, computed camera positions and a sparse point cloud will be displayed.

You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches between any two images use View Matches... command from a photo context menu in the Photos pane.

Metashape supports coordinate system definition based on ground on control points' (markers') coordinates and/or camera coordinates. In both cases the coordinates are specified in the Reference pane and can be either loaded from the external file or typed in manually. Initially Metashape expects both GCPs and camera coordinates data to be specified in the same coordinate system and assigns it as the coordinate system of the chunk. In such a case all outputs by default will be referenced in this particular coordinate system.


Import CSV file (camera position)

1. Click Import toolbar button on the Reference pane. Browse to the file containing recorded reference coordinates and click Open button. 


2. In the Import CSV dialog set the coordinate system, select the delimiter and indicate the column index for each coordinate. Indicate columns for the orientation data if present. Optionally, indicate accuracy values for coordinates and rotation angles.


3. Click OK button. The reference coordinates data will be loaded onto the Reference pane

Note: 

  • If reference coordinates of a marker/camera position for a photo are not specified in the loading file the current value will be kept for them.


Add Markers

Markers can be specified in one of the following ways:

- Imported from a separate test file (using character separated values format);

- Entered manually in the Reference pane. 


1. Click Import toolbar button on the Reference pane (to open Reference pane use Reference command from the View menu). Browse to the file with Ground Control Points (GCPs) and coordinates, click Open button. 


2. In the Import CSV dialog set the coordinate system if the data presents geographical coordinates. 


3. Select the delimiter and indicate the number of the data column for each coordinate.


4. Click OK button.



5. Open the photo where the marker is visible by double clicking on the photo's name. Automatically placed marker will be indicated with icon. To filter photos by marker use Filter by Markers command from the 3D view context menu.

6. Switch to the marker editing mode using Edit Markers toolbar button. Move the marker projection to the desired location by dragging it using left mouse button. Once marker location is refined by user, the marker icon will change to  

Ground control and check points 

In Metashape you can use 2 types of markers. They are control and check points. Control points are used to reference the model. While check points are used to validate accuracy of the camera alignment and optimization procedures results.


1. Select marker on the Reference pane.


2. Ensure that the selected marker has at least 2 projections placed on the aligned images. You should check point box. If the check box is enabled, the point is the control point. When check box is disable, the point is the check point. 


3. Control and check point errors can be inspected on the Errors Values tab.


NOTE: After you change the point type click Update toolbar button from the Reference pane.


Optimize Camera Alignment parameters 

Metashape estimates internal and external orientation parameters during photo alignment. Possible non-linear deformations of the model can be removed by optimizing the estimated point cloud and camera parameters based on the known reference coordinates. During this optimization Metashape adjusts estimated point  coordinates and camera parameters minimizing the sum of reprojection error and reference coordinate misalignment error.



Build Dense Cloud 

1. Check the reconstruction volume bounding box. 

2. Select the Build Dense Cloud... command from the Workflow menu.


3. In the Build Dense Cloud dialog box select the desired reconstruction parameters. 

NOTE: You can enable calculate point confidence parameter, which represents the number of depth maps used for the given point generation. The noisy areas of the dense cloud will have lower confidence and you with the help of the dense point cloud filtering and noisy points can be deleted (Tools Menu -> Dense Cloud -> Filter by Confidence).


4. Click OK button when done.

 

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button. 

Build DEM

Metashape allows to generate and visualize a digital elevation model (DEM). A DEM represents a surface model as a regular grid of height values. DEM can be rasterized from a dense point cloud, a sparse point cloud, a depth maps or a mesh. Note: Build DEM procedure can be performed only for projects saved in .PSX format. Dem can be calculated for referenced or scaled projects only. 


1. Select the Build DEM... command from the Workflow menu. 


2. In the Build DEM dialog box set Coordinate system for the DEM or choose the projection type. Select source data for DEM rasterization.


3. Click OK button when done. 


4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

You can find some information about DEM in our solution: DEM Generation, DEM based measurements.


Export DEM 

1. Select Export DEM... command from the File menu. 


2. In the Export DEM dialog specify coordinate system to georeference the DEM.

3. Click Export button to start export. 


4. Browse the destination folder, choose the file type, and print in the file name. Click Save button. 


5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button. 


Build Orthomosaic 

Orthomosaic is obtained by orthorectification of the original images. Metashape enables to perform orthomosaic Seamline editing for better visual results. You can read more information about Seamline editing, Generation Orthomosaic (geographic projection) in our solutions.


1. Select the Build Orthomosaic... command from the Workflow menu. 


2. In the Build Orthomosaic dialog box set Coordinate system for the Orthomosaic referencing of select projection type. Select type of Surface data that will be used to build the orthomosaic.

3. Click OK button when done.


4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Orthomosaic export

1. Select Export Orthomosaic... command from the File menu. 


2. In the Export Orthomosaic dialog box specify coordinate system for the Orthomosaic to be saved in.


3. Click Export... button to start export. 


4. Browse the destination folder, choose the file type, and print in the file name. Click Save button. 


5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.



Upload Data

Metashape support direct uploading of the generated data (Sparse cloud, Dense cloud, DEM, Orthomosaic) to various online resources: 4DMapper, Mapbox, Melown Cloud, Picterra, PointBox, Pointscene, Sketchfab, Sputnik. To publish your model online use Upload Data... command from the File menu.